Unable to successfully test epgm:// protocol on Windows

Description

Perhaps it is simply user error, but I just cannot seem to get the epgm:// protocol support to work successfully on Windows. Depending on the epgm://device;address string I use I get either "No such device" errors or I get assertion errors.

Is there some special way of filling out the device portion of the connect/bind string specific to Windows? I've tried the obvious primary IPv4 address of the NIC but I just get back that no such device error. I've also tried link-local but that doesn't seem to properly send/recv any messages. It does pass the zmq_bind stage, but I don't want to test link-local, if it is just an alias for the loopback adapter that I assume it is.

Ill have to crack open the openpgm example programs and test those out.

It would really help if someone could point me in the right direction here if I'm just doing something wrong or don't have the library built correctly on Windows. I used the MSVC solution configuration WithPgmSupport or whatever it was called and installed miru's binary dist build of opengm. Everything built fine with 0 errors and libzmq definitely appears to talk to openpgm but I can't get beyond the zmq_bind stage without erroring or asserting out.

Environment

None

Status

Assignee

Unassigned

Reporter

JamesDunne

Labels

None

Priority