In version 2.0.x, libzmq has a soname (library version) of 0.0.0

Description

In both Ubuntu 10.10 and Fedora 14, library files don't have version in name:

/usr/lib/libzmq.so
/usr/lib/libzmq.so.0
/usr/lib/libzmq.so.0.0.0

This introduces some problems, because 2.1 and 2.0 have different API.

Environment

None

Status

Assignee

Unassigned

Reporter

mkevac

Labels

None

Priority